Back to overview
Degraded
Long Response Times Due to High Demand
May 28 at 10:48pm IST
Affected services
app.formbricks.com/health
Resolved
Jun 04 at 03:44am IST
All issues with Formbricks Cloud have been resolved, and all systems are running smoothly again.
Thanks for your patience and support!
Affected services
Created
May 28 at 10:48pm IST
We are currently experiencing longer-than-usual response times on Formbricks Cloud due to high demand.
Our team is actively working on a fix to reduce response times and improve the overall performance and experience.
Thank you for your patience and understanding!
Affected services